Utilisation d’un GPS avec Navigation

Depuis la version 2.1, Navigation supporte la connexion avec un GPS. Les GPS de marque Magellan, Garmin, MLR et AvMap sont complètement pris en charge (points, routes, traces), en lecture (GPS vers PC) et en écriture (PC vers GPS). Les GPS de marque Lowrance sont supportés en lecture comme en écriture au travers des fichiers .USR qu’ils génèrent sur les cartes au format MMC.

Les cartes défilantes sont utilisables avec tous les GPS conformes à la norme NMEA.

Si vous utilisez le mode "Carte déroulante" avec un GPS Garmin, je vous conseille de le configurer en mode NMEA, qui donne beaucoup plus d’informations que le mode PVT propriétaire Garmin.

Les fonctions disponibles avec un GPS

Ces fonctions sont disponibles au travers du menu GPS

·         Suivi de la route en temps réel sur une carte défilante à l’aide de la connexion GPS (ainsi que Flight Simulator, X-Plane (32 et 64 bits) et FlightGear).

·         Recherche des AD les plus proches, et calcul de route après choix.

·         Utilisation d'un point quelconque comme destination (Goto).

·         Affichage des VAC sauvegardées sur le PC.

·         Récupération et sauvegarde sur le PC des :

·         Traces du GPS (track).

·         Routes.

·         Points (waypoints).

·         Chargement de la route courante (avec éventuellement l’ajout de points voisins de la route) dans un GPSMagellan, Garmin, MLR, AvMap, Lowrance, BayoExplorer, TomTom, MGL ou de créer un fichier au format Acs, Bayo, Flight Simulator (standard et XML), Pro Flight Planner, Google Earth, GPX (standard, avec points, Garmin et Magellan), Lowrance (avec et sans points), Magellan Explorist, Enigma, OziExplorer, Pegase, TomTom, Waypoint +, WinPilot, Xplane, IVAO, Bendix, Garmin 1000, iVFR, Air Nav Pro, SeeYou (avec et sans points), GpsVP, Lk8000, FlightAssistant et SkyVector.

·         Chargement de points depuis un des GPS supportés ou d'un fichier au format RTE, Waypoint+, Lowrance, Bendix, PCX5, Bayo Explorer, SeeYou, SkyVector, Flight Simulator, Pro Flight Planner, Xplane ou GPX.

·         Destruction d’une route dans le GPS.

·         Affichage sur la carte d’un fichier trace préalablement sauvegardé. En plus des fichiers directement récupérés sur un GPS, il est possible de lire des fichiers au format NMEA, TRK, Waypoint+, CartaLynx, OziExplorer, IGC, GAC, Lowrance, Garlink, Map Source, Delta Route, Magellan, Magellan Explorist, GPS Tuner, Pégasse, Global Sat, Bayo Explorer, GPX, iAéro ApiBox,Bendix, VFR Androîd, Lana 2, Google Earth et Garmin 1000.

·         Import de points au format WPT, Waypoint+, Lowrance, Magellan, Google Earth, See You ainsi que des plans de vol de Flight Simulator, X-Plane, ACS GPS ou GPX.

·         Affichage sur la carte d’un fichier route préalablement sauvegardé (pratique pour créer une navigation à partir d’une route GPS).

·         Affichage sur la carte d’une route en temps réel préalablement enregistrée.

·         Affichage sur un graphique de 2 informations parmi vitesse, accélération, altitude, hauteur, Vz.

·         Affichage en rouge des parties du terrain sous l’altitude de l’avion (en mode carte déroulante)

Restrictions liées aux GPS AvMap

La bonne nouvelle, c'est que Navigation supporte les AvMap. La mauvaise, c'est que ce type de GPS n'est pas très ergonomique, dès qu'on le connecte à un PC. La principale différence qu'on peut noter, par rapport à l'ensemble des autres, c'est qu'il n'est pas possible de lui envoyer des commandes.

Par exemple, lorsqu'on souhaite récupérer la liste des traces du GPS, Navigation demande au GPS "donne-moi la liste des traces" à l'aide d'une commande adéquate. Sur un AvMap, il n'y a pas de commande, Navigation demande à l'utilisateur "il serait bien de demander au GPS d'envoyer la liste des traces". L'utilisateur, au travers des menus du GPS, doit activer la fonction "Envoi de la liste des traces". Sur un EKP IV, on l'obtient en appuyant une seconde sur la touche "MENU", puis "Communications" + "Enter". Choisir ensuite "Track download" + "Enter". Ce n’est pas très ergonomique. C'est d'ailleurs, à ma connaissance, la seule marque de GPS qui fonctionne de cette façon.

Si on accepte cette restriction, le fonctionnement des GPS AvMap, pour navigation, est identique aux autres marques.

Particularités des GPS Lowrance

Les GPS Lowrance sont supportés au travers des fichiers .USR générés sur les cartes MMC. Contrairement aux autres GPS, il n’y a pas de connexion directe par câble avec le GPS. C’est pourquoi on doit utiliser le menu GPS > Fichier > Fichier trace ou Fichier route ou Fichier points pour lire les .USR (en ayant choisi dans la fenêtre d’ouverture de fichier le type Lowrance, extension .USR).

De même, l’enregistrement de la route courante s’effectue au travers du menu GPS > Sauver route > Lowrance.

Particularités des GPS Garmin iQue

Les GPS iQue ne communiquent avec les PC qu’au travers de l’outil de synchronisation des PocketPC (ActiveSync). Il n’est donc possible que d’échanger des fichiers .MPS. C’est pourquoi on doit utiliser le menu GPS > Fichier > Fichier pour lire les .MPS (en ayant choisi dans la fenêtre d’ouverture de fichier le type MapSource, extension .MPS).

Particularités des GPS Garmin Aera

Le Garmin Aera 500 est différent de ses prédécesseurs, en ce sens qu'il ne "cause" pas le protocole Garmin aéro (en fait, il en parle un tout petit bout, avec un câble spécial, mais la plupart des protocoles qu'il connait sont non documentés).

Il fonctionne comme les GPS voiture, par copie de fichiers sur le GPS.

En gros, il faut connecter le GPS avec son câble USB. Windows va créer un périphérique dédié au GPS (par exemple E:, F:, ...), de la même façon que si on avait connecté une clef USB. L'échange de fichier se fait au travers de l'explorateur de fichiers (là encore, toujours comme si c'était une clef USB). Les fichiers intéressants sont les fichiers .GPX. Celui qui contient la route courante et les traces se nomme Current.gpx.

Navigation sait lire/écrire les fichiers GPX, au travers de :

·         "GPS" > "Fichier" > "Fichier trace" (puis choisir le type .GPX) pour lire les traces

·         "GPS" > "Fichier" > "Fichier route" (puis choisir le type .GPX) pour lire les route

·         "GPS" > "Sauver route" > "GPX" pour enregistrer la route courante.

Particularités du logiciel AirNavPro

Navigation supporte le logiciel AirNavPro dans ses versions iPhone et iPad :

·         Soit au travers d'une connexion IP. Dans ce cas, aller dans le menu "Options", onglet "GPS", et préciser dans le type de GPS "AirNavPro". Les menus "GPS" > "GPS->PC", "Récupérer trace" / "Récupérer route" et "GPS" > "PC->GPS" > "Emission de la route courante" sont actives. De plus, il est possible d'exporter les cartes VAC au travers du menu "GPS" > "GPS->PC" > "Chargement des VAC".

·         Soit sans connexion directe. Dans ce cas, utiliser le menu "GPS " > "Exporter la route" > "AirNavPro". Navigation va générer un .GPX au bon format. Il suffira de l'envoyer soit par mail (et de l'intégrer depuis l'interface mail de l'iTruc), soit pas transfert de fichier au travers d'iTunes. Se référer à la doc d'AirNavPro pour plus de détails.

 

Pour ceux qui souhaiteraient ajouter leur propres VAC à l'export, la règle de nommage des PDF doit suivre le format suivant :

Particularités des GPS G1000

Le matériel nécessaire pour le G1000 est une carte SD de 2Go maximum (donc une vieille carte à 5€ en gros) formatée en FAT (pas FAT32).

Il faut la placer dans le G1000 avant sa mise sous tension sinon elle ne sera pas vue.

Le G1000 écrit dessus quelques informations spécifiques (donc elle ne doit pas être verrouillée en écriture).

A partir de là, on fait l'export du .FPL à la racine de la SD depuis un PC et le G1000 reconnaitra les fichiers sans aucun souci.

Le paramétrage du GPS

Le GPS soit être connecté au PC au travers d’un câble série approprié. Dans certains GPS, il faut préciser, dans les préférences du GPS, qu’on souhaite activer la communication sur son port série.

Le support des GPS Garmin au travers d’une liaison USB est également permis.

Le support des GPS Magellan au travers d’une interface USB est également supporté. Le lien USB permet, au travers de l’émulation de ports série, de récupérer les informations de position en temps réel. L’échange de fichiers est lui réalisé au travers du montage "disque virtuel" du GPS.

Pour Navigation, on définit les paramètres du GPS dans les préférences, onglet GPS

La communication correcte avec le GPS est indiquée, au lancement de chaque commande, par un message d’état du type

 

Afin de faciliter la détection de problèmes, on indiquera à l'utilisateur qu'une autre instance de Navigation est active sur la machine en cas de problème de connexion au GPS. En effet, dans certains cas (notamment en utilisation avec un Tablet PC), l'autre instance peut très bien être connectée au GPS et bloquer le port de communication avec le GPS.

Utilisation de la carte déroulante

ATTENTION : ce mode ne doit être utilisé qu'en simulation d'un vol, que ce soit avec la simulation intégrée avec Navigation, ou avec Flight Simulator ou Xplane.

Navigation autorise l’utilisation du GPS pour se positionner en temps réel sur la carte. Une fois le GPS connecté au PC, sélectionnez l’option "GPS", "Position en temps réel". Le comportement de Navigation dépend des messages renvoyés par le GPS (voir la liste des séquences supportées).

ATTENTION : les informations d'altitude sont à utiliser avec précaution car :

·         Navigation peut se tromper (ça s'est déjà vu)

·         Le GPS peut aussi se tromper (y'a pas de raisons que je sois le seul à me gourer ;-)

·         On peut être dans une zone de mauvaise réception

·         L'altitude GPS est donnée par rapport à une sphère parfaite. La terre n'étant pas parfaite, il faut corriger le défaut (connu sous le terme d'ondulation de géoïde (GUND)). L'erreur est de l'ordre de 150 ft en France.

·         L'altitude retournée est entièrement électronique. L'altitude retournée dans l'ensemble des avions alentours est basée sur la pression. A moins d'un énorme coup de pot (QNH égal à 1013.25 hPa), ça a peu de chance d'être équivalent.

·         Le passage en mode standard (1013,25) amène tout le monde sur la même référence de pression. Sans capteur de pression, c'est plus dur.

·         L'altitude AGL est calculée à partir de l'altitude GPS. Elle a toutes les chances d'être fausse, parce que d'une part basée sur l'altitude GPS pas très juste, et ensuite calculée par la hauteur du sol qui est une approximation plus ou moins locale.

Navigation tente bien de palier tant bien que mal à certains problèmes, mais le tout reste artisanal, et ne peut décemment pas être considéré comme fiable.

ATTENTION : les informations de vitesse proviennent du GPS. Au-delà des remarques sur les erreurs GPS et de Navigation, il convient de se rappeler que ce sont des vitesses sol, pas des vitesses air.  L'oublier près du sol est une excellente façon de décrocher …  Bien penser aussi que les index et autres bandes colorées sont calées sur des vitesses air. Comme le GPS envoie des vitesses sol, les indications sont justes fausses de la différence entre la Vi (IAS) et la Vs (GS).

Concernant la vitesse, pour le moment il n'y a pas de moyen d'essayer de calculer la différence. Elle est donc fausse …

Ces fonctions sont présentes pour être utilisées lors de la simulation des vols.

Ceci étant posé, utiliser ces données en vol pour autre chose que faire joli est irresponsable et suicidaire.

Un message d'alerte est affiché à chaque lancement du mode "Suivi temps réel" pour rappeler les approximations de ce mode.

 

 

Lorsque le mode "Suivi temps réel" est activé, les éléments affichés sur l’écran sont modifiés conformément aux paramètres définis dans les options, onglet "GPS ". Par défaut, les barres d’icônes et de sélections sont masquées, les boutons sont affichés.

Les principales informations (altitude ASML, altitude AGL, GS (vitesse sol), CRS (course sol) sont affichées sur les boutons. Si une route est active sur le GPS, le nom du prochain point, le cap et la distance (plus éventuellement l'erreur par rapport à la route réelle), l’ETE (heure estimée au prochain point, sous forme d’heure et de temps), la vitesse indiquée saisie (IAS) et le cap magnétique saisi (HDG) sont également affichés.

Si la trace GPS est active (voir légende), le chemin déjà parcouru est affiché (trait fin vert clair dans l’exemple ci-dessus). De même, si la cible GPS est active, elle sera tracée (trait vert plus foncé), la cible elle-même étant représentée par un "plus". Si une rose est affichée autour de l'avion, le cap est affiché et encadré, un triangle symbolise le cap à prendre pour rejoindre le point suivant.

La position de l’avion, au cap actuel, dans les 10 prochaines minutes est tracée devant lui (le temps se règle dans les options, onglet "GPS", cadre "Projection de la position GPS"). Chaque barre perpendiculaire à la route indique 1 minute.

Dans le cas où la liaison avec le GPS serait perdue, ou dans le cas où le GPS ne se déplace plus, la forme de l’icône de position changera comme ci-dessous :

Si la position du GPS n’est pas valide, elle est affichée en rouge, suivie de l’indication "** POS INVALIDE **". Ceci peut être désactivé dans les options, onglet "GPS"

On peut également demander l’affichage de la fenêtre "Altitude" lorsque la carte déroulante est active, ainsi que la projection de la position dans le futur. En plus de l’avion indiquant le sens de déplacement, le trait indique la position future, dans les minutes suivantes. Les graduations sur ce trait sont en minutes. Il est activé par l’item "Projection" de la fenêtre "Légende". La valeur maximale et l’intervalle de graduation sont paramétrables dans l’onglet GPS des options.

La fenêtre "Altitude" comporte 2 parties. La gauche, jusqu’au premier trait vertical rouge représente le terrain et les zones survolées précédemment. L’altitude passée de l’avion est également représentée. La partie droite, à partir du premier trait vertical, représente les minutes à venir, si l’avion conserve le cap actuel. Dans l’exemple donné, on voit qu’on va entrer dans une zone dans environ 35 secondes, ce qui est corroboré par la projection sur la carte.

L’ensemble de ces infos est évidemment remis à jour en permanence. Pour des raisons de performance, la partie "Altitude" n’est actualisée que toutes les 5 secondes environ (le délai s'ajuste dans les options, onglet "Suivi GPS", cadre "Rafraîchissement", élément "Altitude").

Si on demande l’affichage de la rose avion (dans la fenêtre "Légende"), elle sera tracée autour de la position de l’avion. Le cap actuel est indiqué dans un cadre dont l’extrémité en flèche contient la valeur actuelle (ici 072).

Dans l’exemple précédent, la carte est centrée, le nord en haut.

L’exemple suivant montre la carte centrée, le cap vers le haut.

 

Celui ci, centré, le cap à droite

 

On peut aussi positionner l’avion sur un des bords (il suffit de décocher "Centrer la carte" dans les options, onglet "GPS". L’exemple suivant montre un cap vers le haut.

 

Celui-ci, un cap vers la droite

 

 

En cliquant sur l’icône , on obtient l’affichage en rouge des parties de la carte dont l’altitude est inférieure de 100 ft à celle de l’avion (risque de collision). Les zones inférieures à 500 ft sont, elles, indiquées en jaune.

Si on demande l’affichage des obstacles, ceux qui sont conflictuels (devant l’avion, moins de 500 ft) clignoteront en rouge.

Le mode "Zoom automatique" permet de lier l’échelle de l’écran à l’altitude de l’avion. Il est sélectionné automatiquement lors de l’activation du mode "Suivi temps réel". Le fait de changer manuellement le niveau de zoom le désactive.

Comme le montrent les écrans précédents, il est possible d'afficher, de chaque côté de l'écran, des rubans indiquant la vitesse et l'altitude de l'avion.

Le fond et le côté gauche du ruban "Altitude" réagit de la façon suivante :

·         Il est coloré en rouge sur la largeur complète sous l'altitude AGL du point courant

·         Il est coloré en rouge sur le côté du ruban en dessous de l'altitude AGL du point courant + la valeur spécifiée dans la zone "Rouge à partir de" dans le cadre "Alerte sol proche"

·         Il est coloré en orange sur le côté du ruban en dessous de l'altitude AGL du point courant + la moitié de la valeur spécifiée dans les zones "Rouge à partir de" et "Jaune à partir de" dans le cadre "Alerte sol proche"

·         Il est coloré en jaune sur le côté du ruban en dessous de l'altitude AGL du point courant + la valeur "Jaune à partir de" dans le cadre "Alerte sol proche"

Par exemple, si la zone rouge est définie à 500 ft, et la jaune à 1000 ft, le coté du ruban sera rouge jusqu'à AGL + 500 ft, orange de 500 ft à 750 ft, et jaune de 750 ft à 1000 ft.

ATTENTION : bien se rappeler que les altitudes sont des approximations basées sur les altitudes GPS d'une part, et sur une estimation de la hauteur du sol de l'autre. Elles ne doivent être utilisées que pour la simulation d'un vol.

Les rubans sont remplacés par le graphisme suivant lorsque le GPS n'envoie plus d'informations pendant 3 secondes.

Affichage des infos autour du point courant

Un simple clic (ou toucher de la carte dans le cas d'écran tactile) affiche une fenêtre regroupant toutes les infos relatives aux éléments autour du point touché ou autour de l'avion.

Cette fenêtre ressemble à :

 

Le choix actif est représenté sur un fond gris, les autres sont en blanc.

Par défaut, ce sont les éléments devant l'avion qui sont affichées. On bascule sur les infos autour du clic/point touché en cliquant sur le bouton correspondant.

Les éléments sont montrés du temps qu'il faudra pour les atteindre, en ordre croissant. Le calcul est réalisé sur la vitesse courante de l'avion ou sur la vitesse de croisière si l'avion est au sol.

Noter que des barres de défilement permettent de déplacer la partie visible de la fenêtre verticalement et/ou horizontalement. Un cliquer/glisser à la souris ou au doigt sur la fenêtre permet également ce déplacement.

Visualisation des AD

En cliquant sur le bouton point, on obtient la liste des AD (autour du clic ou devant l'avion, comme choisi précédemment).

 

En cliquant sur AD, on peut choisir le type d'AD à visualiser.

Visualisation des aides radio

Quand "Points" est actif, cliquer sur "Radio" pour voir les VOR (par défaut) ou NDB (en cliquant dessus).

Visualisation des points de report

Toujours sur "Points", cliquer sur "Report" permet d'afficher ces points.

Visualisation des autres types de points

Enfin sur "Points", "Autres" permet de visualiser les types suivants :

Visualisation des espaces aériens

Cliquer sur "Espaces" pour afficher des infos sur les classes, zones ou SIV/FIS

Visualisation des points de la route

Si une route est définie, cliquer sur "Route" pour voir l'ensemble des points tournants classés d'après leur distance à l'avion.

Note : contrairement aux autres onglets, les temps sont calculés à partir de la vitesse GPS pour la branche courante, et du temps avec vent pour les autres branches.

 

Visualisation des détails d'un élément

Enfin, si ou clique/touche une ligne, les détails de cette ligne sont visualisés de la façon suivante :

Selon le type, les boutons "Voir" (fait clignoter l'élément sur la carte), "Goto" (définit le prochain point de la navigation), "Ref." (définit la référence sur le point) ou "VAC" (affiche les VAC de l'AD) permettent simplement de réaliser des fonctions de base.

Recherche des AD les plus proches

Il est possible d’afficher, lorsque la carte déroulante est active, de montrer au minimum les 3 AD les plus proches de la position actuelle. Cet affichage peut être demandé, soit par le menu "GPS" > "AD proches", soit en cliquant sur "AD proches" des boutons. Voici un exemple d’affichage :

Les informations de cap, distance de l’AD, ses nom, altitude, fréquence radio, et le détail de ses pistes sont affichés. Ces informations disparaissent après une minute.

Il suffit de cliquer dans les environs (quelques centimètres) d’un AD pour qu’il devienne automatiquement le point de Navigation. Ses cap, distance, ETE sont alors affichés.

On peut annuler ce point en cliquant sur "Goto" pour le désactiver.

Noter que l’ensemble des exemples donnés ci-dessus montrent une orientation de carte "Nord en haut". Il est possible, dans les options, onglet "GPS", d’orienter la trace avec le cap courant vers le haut de l’écran, ou vers la droite de l’écran.

Concernant la sélection du bouton "AD proche" (tout comme "Goto", "Référence" et "VAC" décrit plus bas), le fait de cliquer dessus efface les boutons et rubans jusqu'à ce qu'on sélectionne un point. De plus, si on ne sélectionne pas d'AD dans les 10 secondes, la sélection s'annule seule).

Fonction Goto

La fonction Goto permet d'utiliser n'importe quel point affiché à l'écran comme destination. Pour activer la fonction, il suffit de cliquer sur le bouton "Goto" des boutons, ou utiliser le menu "GPS" > "Goto", puis de cliquer sur le point désiré. On annule le Goto en cliquant sur le bouton "Goto" ou sur le bouton "Next". Ne pas oublier, soit de définir un autre point, soit d'annuler le "GoTo" lorsqu'on a dépassé le point recherché.

Fonction VAC

La fonction VAC permet d'afficher les documents d'un AD. Comme pour les fonctions "AD Proches" "Référence" et 'Goto", il faut d'abord appuyer sur le bouton "VAC", puis appuyer dans le voisinage de l'AD concerné.

Fonction Référence

La fonction "Référence" permet de choisir un point de référence (indépendant de la destination actuelle, qu'elle soit le prochain point de la nav, ou le Goto actif), et d'obtenir des infos distance, cap et temps de la position actuelle à cette référence.

Cliquer sur "Référence", puis sur le point qu'on souhaite définir en tant que référence. Il est possible de zoomer en avant ou en arrière et/ou de déplacer la carte pour définir ce point.

Une fois défini, le bouton "Référence" (par défaut en haut à droite), change et affiche le nom du point, le cap, la distance et le temps de la position actuelle à la référence.

Pour effacer la référence, cliquer une nouvelle fois sur le bouton.

 

Gestion du QNH

Les GPS donnent des altitudes "réelles", quelle que soit la pression atmosphérique. Cette altitude serait celle qu'indiquerait un GPS calé au QNH local (à condition que le QNH soit juste).

Lorsqu'on passe, sur l'altimètre de l'avion, du QHN à la référence standard 1013.25, on induit une différence entre l'affichage de l'altitude GPS et celle de l'altimètre de l'avion. Le fait d'utiliser un calage standard permet de d'avoir une référence commune (et connue).

Au passage, un des effets de bord de cette façon de faire est que l'altitude commune est fausse par rapport à l'altitude réelle. Ça pose des soucis, notamment quand le QNH est sous 1013,25, parce que l'altitude réelle est inférieure à l'altitude indiquée par l'altimètre calé en STD.  Il convient donc d'être prudent quand le QNH est particulièrement bas, de façon indépendante de Navigation.

Ceci posé, il est possible de corriger cette différence, et d'afficher l'altitude telle quelle serait lue, pour un QNH local donné, sur un altimètre calé à 1013.25 (indiqué "Std" pour Standard).

Contrairement à l'avion, où il faut s'assurer que le QNH est correct lorsqu'on repasse au QNH, le GPS indiquant en permanence l'altitude réelle, la conversion n'est réalisée que lorsqu'on sélectionne le mode "STD". Il est donc important que le QNH local soit indiqué quand on utilise le mode "STD" (et paradoxalement pas quand on utilise le mode "QNH", puisqu'il n'y a pas de correction dans ce cas). Un message d'alerte rappelle tous les quarts d'heure qu'il faut penser à recaler le QNH lorsqu'on vole en niveau standard.

Lorsqu'on lance Navigation, il n'y a pas de QNH connu, le ruban "Altitude" indique GPS, et affiche l'altitude donnée par le GPS.

 

 

Si on clique sur le bouton "QNH", on affiche un clavier virtuel au-dessus de l'image. On peut alors :

·         Soit saisir chiffre par chiffre la valeur du QNH et on valide par "Ok". Si la valeur n'est pas comprise entre 952 et 1048, elle est remise à zéro et il faut ressaisir (ou utiliser une des touches suivantes).

·         Soit cliquer sur "C" pour effacer le dernier chiffre

·         Soit cliquer sur "X" pour fermer la fenêtre sans rien modifier

·         Soit cliquer sur "RAZ" pour effacer la valeur du QNH (et on repassera en affichage "GPS", comme au lancement de Navigation)

 

Une fois le QNH validé, il est affiché dans le bouton QNH et dans le ruban "Altitude", et l'altitude affichée reste l'altitude GPS.

 

Si on clique sur le bouton "Std", on passe au calage standard (1013.25). Navigation va corriger l'altitude de la différence entre le QNH indiqué et 1013,25 pour indiquer la même information qu'un altimètre atmosphérique. Le ruban "Altitude" indique "Std". Le bouton "Std" est encadré pour indiquer que l'altitude est calée au niveau standard, le bouton "QNH" est également encadré pour indiquer que l'altitude est affichée en utilisant un QNH local (voir plus haut les explications). L'altitude GPS est toujours indiquée dans le bouton "AMSL", la hauteur par rapport au sol est toujours indiquée dans le bouton "AGL", et sont toujours correctes (aux erreurs cumulées de Navigation et du GPS près ;-).

Un message d'alerte toutes les 15 minutes nous invite à corriger éventuellement le QNH local, afin de s'assurer que la correction n'est pas trop fausse …

ATTENTION : bien se rappeler que cette information est entachée d'erreur, et ne doit être utilisée qu'en simulation.

Affichage de données sous forme graphique

Par défaut, les données vitesse et altitude sont tracées sur un graphe positionnable soit en haut de l’écran, soit en bas, soit flottant sur l’écran. Pour positionner le graphique, il suffit de cliquer sur la barre de titre, de conserver le bouton de souris appuyé, et de déplacer la fenêtre avec la souris. Lâcher le bouton de souris lorsque la position souhaitée et atteinte. Voici un exemple de route avec graphique :

Si on clique sur un des points des courbes, le symbole de positionnement GPS (la cible) sera affiché sur la carte à la position qui correspond aux données présentées sous forme graphique.

Modification des données affichées

Il est possible de modifier les données affichées à l’aide d’un menu. Pour activer ce menu, faites un clic droit dans la fenêtre graphique (ou utilisez le menu "Courbe"). Le menu suivant s’affiche :

Les choix suivants sont proposés :

·         Affichage : choix du type de graphique

·         Courbe

·         Aire

·         Courbe 1

·         Choix du graphique 1 :

·         Vs (vitesse sol)

·         Accélération

·         Altitude (ASML)

·         Hauteur (AGL)

·         Vz

·         Choix de l’échelle

·         0 – Max

·         Min – Max

·         Courbe 2 : identique à Courbe 1, le choix "rien" permet de ne pas afficher de seconde courbe

·         Moyenne : permet d’indiquer à Navigation sur combien d’échantillons établir une moyenne, afin de lisser les courbes, et de modérer les erreurs de mesures du GPS.

Les couleurs et épaisseurs des traits du graphique, ainsi que la couleur de fond du graphique sont réglable dans les préférences.

Nom des fichiers liés au GPS

Les fichiers liés au GPS sont stockés dans le répertoire des fichiers relatifs au GPS, qui est donné dans les préférences. Par défaut, ce répertoire est nommé GPS, et localisé dans le répertoire principal de Navigation.

Le format des noms de fichiers est de la forme <siècle><mois><jour>_<heure><minute><seconde>. Par exemple 20020117_230514. Suivant les cas, la date utilisée est celle du jour de l’enregistrement des informations (cas de la trace), ou la date actuelle.

Sauvegarde des informations du GPS

Il est possible de sauvegarder sur le PC les informations suivantes du GPS :

·         Traces du GPS. La date retenue pour le fichier sera celle de l’enregistrement du premier point, l’extension .TRK

La trace GPS sera ensuite affichée sur la carte. Voici à quoi peut ressembler un Brive / Paris par la route :

·         Routes. La date retenue sera la date du jour, l’extension .RTE

·         Points. La date retenue sera la date du jour, l’extension .WPT. De plus, les points seront disponibles, et affichés dans la catégorie "Autres".

Chargement d’informations dans le GPS

Il est également possible de charger (ou détruire) des informations dans le GPS. On peut :

·         Charger de la route courante dans le GPS. Après avoir analysé les routes présentes dans le GPS, une fenêtre de choix est proposée. Le système vous propose par défaut la première route disponible. Il est possible d’écraser une route existante en la sélectionnant.

·         Détruire une route dans le GPS. Le même choix que précédemment est proposé. De plus, on demande la confirmation de la destruction par un message du type :

·         Chargement d’un fichier points (préalablement sauvegardé) du disque dur vers le GPS. Le choix du fichier à utiliser est réalisé au travers d’une boite de dialogue telle que :

·         Chargement d’un fichier route (préalablement sauvegardé) du disque dur vers le GPS. Même principe que précédemment, mais on demande de sélectionner le fichier route et le fichier points associé.

Affichage d’informations sauvegardées sur le PC

Il est possible d’afficher sur la carte des données sauvegardées depuis le GPS sur le PC. Cette possibilité est offerte pour les traces, les routes et les suivis de route en temps réel.

On peut afficher sur la carte :

·         Un fichier trace préalablement sauvegardé. On demandera le nom du fichier trace à utiliser.

·         Un fichier route préalablement sauvegardé. On demandera le nom du fichier route à utiliser, et celui du fichier points associé.

·         Une route en temps réel préalablement enregistrée. On demandera le(s) nom(s) du/des fichiers à utiliser. Pour sélectionner plusieurs fichiers, sélectionner d’abord un fichier, puis utiliser <Shift> clic ou sélectionner tous les fichiers compris entre le premier fichier sélectionné, et le fichier cliqué, ou <Contrôle> clic pour ajouter un fichier à la sélection courante. Notez qu’il est possible d’interrompre l’affichage du/des fichier(s) en utilisant la touche <Echap> ou <Esc>.

·         Un fichier points. Les points seront affichés dans la catégorie "Autre".

Trace des échanges avec le GPS

Afin de faciliter la détermination de problèmes, Navigation conserve une trace des échanges avec le GPS dans un fichier d’extension .GPS. Sa lecture peut être édifiante pour les curieux.

La taille du fichier est limitée à 1 Mo. Lorsqu’il atteint cette taille, un nouveau fichier est créé. Vous pouvez détruire ces fichiers sans problèmes, mais vous perdez la possibilité de rejouer un suivi de route en temps réel.

Séquences NMEA supportées

Voici les informations utilisées, et les séquences NMEA qui sont supportées par Navigation :

·         Altitude : $GPGGA

·         Cap actuel : $GPRMC, $GPVTG

·         Date : $GPRMC

·         Déclinaison : $GPRMC

·         Destination (cap, distance, latitude, longitude, nom) : $GPRMB

·         Erreur de route (direction, valeur) : $GPRMB

·         Heure : $GPGGA, $GPGLL, $GPRMC

·         Latitude : $GPGGA, $GPGLL, $GPRMC

·         Longitude : $GPGGA, $GPGLL, $GPRMC

·         Satellites (utilisables, utilisés) : $GPGGA

·         Vitesse : $GPRMC, $GPVTG

Les messages d’erreur liés au GPS

Un certain nombre de messages sont affichés par le programme dans différentes situations anormales. Voici ce qu’affiche Navigation en cas de :

·         Non réponse du GPS à une commande, après 5 secondes

·         Arrêt d’envoi de séquences de positionnement pendant 5 secondes

·         Erreurs répétées de séquences de contrôle de transmission (CRC)

·         Envoi d’une séquence non comprise ou non attendue

Spécificité du mode simulation

Le mode "Simu_Navigation" (qu'on peut choisir comme type de GPS dans l'onglet "GPS" des options) permet de simuler un vol en accéléré.

Il est possible d'interagir avec la simulation au travers de la fenêtre "GPS", activable soit au travers de l'icône GPS (), soit au travers du menu "Affichage" > "GPS".

La case à cocher "Route" indique qu'on souhaite suivre la route courante (ce qui revient à simuler la nav active). Elle est utilisée par défaut si une navigation est chargée.

Dans le cas contraire, il est possible d'indiquer à Navigation quelles sont les valeurs cibles de la course, de la vitesse et de l'altitude, ainsi que le coefficient multiplicateur de la Navigation.

De plus les touches suivantes permettent, lorsque la fenêtre "GPS" est active (comprendre possède le clavier), de modifier les valeurs de ces paramètres :

 

Fichier trace spécifique

En plus des formats de fichier détaillés plus haut, Navigation supporte 2 formats de fichier textes simples :

 

Ces 2 formats permettent de visualiser simplement des contours sur une carte