Foire aux questions

·         Où trouver de l’aide ?

·         J’ai un message m’indiquant un problème de DLL/OCX

·         Je ne comprends pas comment installer Librairies.exe

·         Comment signaler une erreur dans Navigation ?

·         J’ai des problèmes de téléchargement de Versions.zip

·         J’ai un problème avec Kaspersky sur ma machine

·         Comment installer Navigation sous Linux

·         Comment installer Navigation sous MAC

·         J’ai un problème de chargement des détails

·         Je ne vois pas bien la différence après le chargement des détails

·         Quels sont les formats autorisés pour spécifier une latitude/longitude ?

·         Quel est le format autorisé pour spécifier une déclinaison ?

·         Je pense que mon anti-virus me pose un problème. Puis je le désactiver ?

·         D’où viennent les cartes utilisées par Navigation. Qui les édite ?

·         Comment se procurer un exemplaire de la CartaBossy numérique ?

·         Utilisation des cartes IGN France OACI

·         Le fond de mes cartes est uniforme, alors qu’avant la couleur dépendait de l’altitude. Que faire ?

·         Quelles différences entre cartes, vecteurs et données aéro ?

·         Pourquoi les vecteurs ne s’affichent ils pas chez moi ?

·         Comment télécharger les vecteurs dans le cas d’une installation sans connexion à Internet ?

·         Comment afficher les cartes VAC dans Navigation ?

·         J'ai eu une erreur pendant le téléchargement. En relançant, les mêmes fichiers sont retéléchargés. Pourquoi ?

·         Les cartes apparaissent aplaties

·         Je n’arrive pas à utiliser mon GPS

·         Comment connecter mon GPS Garmin à Navigation ?

·         Pourquoi ai-je des doublons dans mon GPS lors du chargement d’une route depuis Navigation ?

·         Comment réaliser une nav circulaire ?

·         J’ai une erreur 440 "Erreur Automation" lors de l’édition de mon log de nav

·         Où trouver les services pack 1 et 2 pour Office 97 français ?

·         Quelle est la version minimale d’OpenOffice supportée ?

Où trouver de l’aide ?

Bon début, vous êtes déjà dans le bon fichier. Les FAQ sont donc le premier endroit où on trouve des réponses aux questions courantes.

Ensuite, on peut lire avec intérêt l’aide. Pour les courageux, il y a la lecture séquentielle, de la première à la dernière page. Pour les organisés, on utilise l’onglet "Sommaire", et on cherche de façon logique quel(s) chapitre(s) peux(vent) bien donner des informations sur un sujet. Les malins, eux, vont cliquer sur l’onglet "Rechercher", qui analyse l’ensemble du texte, et essaient quelques mots clefs bien sentis.

Les chanceux munis d’un accès Internet peuvent aussi utiliser le forum de Navigation (http://groups.google.com/group/Forum-NAVIGATION). L’inscription se fait depuis la page d’accueil de mon site (http://francois.fouchet.free.fr). La modification et la résiliation de l’abonnement se font à http://groups.google.com/group/Forum-NAVIGATION/subscribe

En dernier recours, on peut m’écrire à l’adresse indiquée sur l’écran d’accueil de Navigation.

J’ai un message m’indiquant un problème de DLL/OCX

Réinstallez la dernière version de Librairies.exe, depuis mon site (le fichier se trouve à http://francois.fouchet.free.fr/Navigation/Telechargement/Librairies.exe) pour corriger le problème.

Si le problème persiste, trouver ce qui a été modifié relève du vaudou sans l'aide d'outils (assez astucieusement, le message d'erreur de Microsoft, plutôt que de dire "il y a un problème avec xxx.dll que je ne trouve pas" ou "il y a un problème avec xxx.dll qui n'est pas bien enregistrée", indique le nom de la DLL racine. Quand on sait que ça peut descendre de 4 ou 5 niveaux, et qu'il est courant d'avoir quelques dizaines (voire centaines) de DLL/OCX dans un prog, ça permet d'avoir une idée de la complexité du défi ;-)

Les cas les plus simples se règlent en procédant de la façon suivante :

1.       Faire tourner le programme ShowDLL.exe, présent dans le répertoire d'installation de Navigation (par défaut C:\Program Files\FouFou\Navigation)

2.       Me renvoyer, zippé, le fichier ShowDLL.log qu'il va générer au même endroit

Attention, selon les options de l'explorateur de fichiers, Windows peut cacher les extensions de fichiers connues. Du coup, les fichiers ShowDLL.log (comme Navigation.log et NavigationMAJ.log) sont affichés simplement "ShowDLL" ("Navigation" ou "NavigationMAJ") et leur type passe à "Document texte".

Pour voir correctement les noms complets, lancer l'explorateur de fichiers (touche <Windows> + "E"), "Outils" > "Options des dossiers", onglet "Affichage", décocher "Masquez les extensions des fichiers dont le type est connu".

Les cas plus tordus se règlent en avec les incantations suivantes :

1.       Télécharger http://francois.fouchet.free.fr/Navigation/Telechargement/depends22_x86.zip

2.       Décompresser le contenu dans un répertoire

3.       Lancer depends.exe

4.       Menu "File" > "Open"

5.       Sélectionner Navigation.exe dans le répertoire où il est installé (par défaut C:\Program Files\FouFou\Navigation\)

6.       Si une erreur autre que "Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module." est affichée après l'ouverture, copier/coller le texte de l'erreur dans un mail, et me l'envoyer.

7.       Sinon,"Profile" > "Start Profiling"

8.       Utiliser Navigation et reproduire l'erreur.

9.       De retour dans depends.exe, "File" > "Save as" et enregistrer sous le fichier sur disque (Navigation.dwi)

10.   M'envoyer le fichier (relire le passage sur les extensions cachées plus haut si on ne trouve pas le fichier).

Il est possible de détruire le fichier .dwi, ce n'est qu'une trace.

Les âmes bricoleuses peuvent tenter de lire le log, s'il manque un fichier, c'est indiqué. Pour éviter de fausses joies, et recherche une DLL qui n'existe pas, il faut savoir que dans certains cas Windows cherche des fichiers dans la langue d'installation de la machine (en général en français chez nous, donc intégrant "FR" dans le nom). Ne pas les trouver n'est pas forcement une erreur, les messages en anglais seront alors utilisés.

Une fois en possession des fichiers ShowDLL.log et Navigation.dwi (ou NavigationMAJ.dwi si le souci vient de l'outil de mise à jour), je peux tenter de trouver ce qui cloche.

Je ne comprends pas comment installer Librairies.exe

Voici une façon plus détaillée de procéder à l’installation de Librairies.exe :

1.       Téléchargez Librairies.exe depuis mon site.

2.       Double cliquez dessus, et suivez les étapes pas à pas.

3.       Détruisez le fichier librairies.exe qui n'a plus besoin d'être sur votre disque dur.

Comment signaler une erreur dans Navigation ?

Navigation est composé de 3 modules (programmes) : Navigation, NavigationMAJ et NAvigationConfig. Le premier est le programme principal, le second l'outil de mise à jour, le dernier l'outil de configuration.

En cas de problèmes, j'ai besoin d'un maximum d'informations. Par exemple, savoir lequel des 3 programmes pose un problème (Navigation, NavigationMAJ ou NavigationConfig?), connaître exactement le message qui est affiché (il y a des informations précieuses sur la ligne de code qui cause le problème dans le message), et savoir quel était le contexte (par exemple, j'ai fait un clic droit sur tel AD, et j'ai eu le plantage).

Pour faciliter la tâche de report d'erreur, chaque programme génère un fichier log (nommés Navigation.log, NavigationMAJ.log et NavigationConfig.log), qui contiennent tout un tas de détails utiles (vous pouvez les lire, ils sont au format texte). Il est habile de les attacher au mail que vous m'envoyez pour me faciliter la tâche.

NB: l'ensemble des fichiers indiqués ci-dessus se trouvent dans le répertoire d'installation de Navigation (celui précisé au moment du lancement de NavigationAmorce, la première fois que vous installez Navigation). Par défaut, ce répertoire est C:\Program Files\FouFou\Navigation.
Attention, selon les options de l'explorateur de fichiers, Windows peut cacher les extensions de fichiers connues. Du coup, ces fichiers .log sont affichés simplement "Navigation", "NavigationMAJ" et "NavigationConfig", et leur type passe à "Document texte".

Pour voir correctement les noms complets, lancer l'explorateur de fichiers (touche <Windows> + "E"), "Outils" > "Options des dossiers", onglet "Affichage", décocher "Masquez les extensions des fichiers dont le type est connu".

J’ai des problèmes de téléchargement de Versions.zip

De façon simple, on peut dire qu'il y a 2 causes possibles : soit le site free.fr n'est pas disponible, soit votre machine n'est pas connectée à Internet.

Dans la majorité des cas, on se trouve dans la seconde situation, mais il arrive de temps en temps que Free ait des problèmes.

Pour démêler le problème, procéder de la façon suivante :

1.       si vous devez établir une connexion à Internet "à la main" (cas de Wanadoo modem par exemple), faites-le. Ça règle le problème, puisque vous n'étiez pas connecté à Internet. Lancez la mise à jour et vérifiez que ça fonctionne bien.

2.       utilisez un navigateur pour vérifier que vous accédez bien à Internet. Allez surfer (voir la page d'accueil) de sites importants comme microsoft.com, ou google. Si vous voyez les pages s'afficher, vous pouvez en conclure que vous avez accès à Internet, passez à l'étape suivante. Sinon, c'est que vous avez un problème de connexion. Utilisez les procédures données par votre provider pour vérifier la configuration. Une fois la connexion rétablie, lancez la mise à jour et vérifier que tout refonctionne bien.

3.       utilisez le navigateur pour afficher la page http://francois.fouchet.free.fr/. Si la page s'affiche, c'est que vous avez accès à mon site avec un browser, et qu'il est actif. A priori, la mise à jour devrait fonctionner. Essayez là.

4.       si la mise à jour ne fonctionne pas, c'est un peu plus compliqué, et ça demande une analyse plus fine. On peut quand même isoler 2 cas fréquents : utilisation d'un firewall personnel ou proxy d'entreprise.

5.       vous avez installé un firewall personnel (ou un système équivalent). Vous devez autoriser les programmes NavigatonMAJ.exe et Navigation.exe à communiquer avec Internet. Dans le détail, ça veut dire utiliser le DNS (port 53) et http (port 80). De plus, pour charger les détails, il faut ouvrir les ports FTP (20 et 21) pour NavigationMAJ.

6.       en entreprise, votre connexion à Internet passe par un proxy (on le vérifie en lançant IE, onglet "Connexion", cliquer sur "Paramètres réseau", et regarder si quelque chose est défini au niveau proxy). Dans ce cas, Navigation détectera automatiquement cette configuration. Dans le cas où ce proxy nécessiterait une authentification, une fenêtre demandera quel utilisateur et mot de passe utiliser (il est possible de les mémoriser pour rendre le processus transparent). Si Navigation ne détecte pas automatiquement le proxy, il faut :

·         sur les machines avec proxyxfg, passer la commande DOS "proxycfg –u" (Menu "Démarrer" > "Exécuter …", saisir "CMD" et passer la commande "proxycfg –u" dans la fenêtre, fermer par "exit")

·         sur les machines 32 bits avec netsh, passer la commande DOS netsh winhttp set proxy proxyname:proxyport, en remplaçant proxyname par le nom ou l'adresse IP du proxy et proxyport par le numéro du port du proxy (Menu "Démarrer" > "Exécuter …", saisir "CMD" et passer la commande " netsh winhttp set proxy proxyname:proxyport" dans la fenêtre, fermer par "exit"),

·         sur les machines 64 bits avec netsh, faire comme décrit pour les machines 32 bits, en passant d'abord la commande "cd c:window\syswow64\" avant la commande netsh.

·         sur les machines à partir de Seven, utiliser "Netsh Winhttp import proxy ie"

Si ça ne fonctionne toujours pas, vous pouvez suivre les consignes d'installation sans accès Internet (dans la doc et sur le site). Il y a une page où on récupère l'ensemble des .zip, on les pose dans le répertoire de Navigation, et on lance NavigationMAJ qui va réaliser l'install (et se planter en fin, en disant qu'il ne peut pas télécharger versions.zip).

Eventuellement, si vous avez un autre PC qui a accès à Internet, vous pouvez également copier sans autre forme de procès le contenu du répertoire C:\Program Files\fouFou\Navigation.

J’ai un problème avec Kaspersky sur ma machine

Il faut indiquer à Kaspersky que Navigation et NavigationMAJ sont des applications fiables. Procéder comme suit :

·         lancer Kaspersky. Cliquer sur "Configuration"

·         dans la rubrique "Paramètres" de la partie gauche, cliquer sur "Menaces et exclusions"

·         cliquer sur "Zone de confiance" dans la partie droite

·         cliquer sur "Applications de confiance"

·         cliquer sur "Ajouter" et indiquer les exécutables Navigation.exe et NavigationMAJ.exe

·         sélectionner "Navigation.exe" et cliquer sur "Modifier"

·         cocher "Ne pas analyser les fichiers ouverts" et "Ne pas surveiller l’activité de l’application" puis valider

·         sélectionner "NavigationMAJ.exe" et cliquer sur "Modifier"

·         cocher "Ne pas analyser les fichiers ouverts" et "Ne pas surveiller l’activité de l’application" puis valider

·         fermer toutes les fenêtres ouvertes

Comment installer Navigation sous Linux

Merci à Laurent Vromman pour la procédure.

Testé avec Wine 0.9.44 (celle fournie avec Debian) :               

·         Télécharger "winetricks" (http://kegel.com/wine/winetricks) et s'en servir pour installer :

Ø  winetricks.sh fakeie6

Ø  winetricks.sh mdac28

Ø  winetricks.sh dcom98

Ø  winetricks.sh corefonts

·         Installer Librairies.exe

·         Copier Program Files\Fichiers Communs\DAO350.DLL dans windows\system32 (cp "./drive_c/Program Files/Fichiers communs/DAO350.dll" "./drive_c/windows/system32")

·         On peut ensuite installer Navigation et NavigationConfigavec NavigationAmorce de manière parfaitement habituelle (wine NavigationAmorce.exe)

·         Il est possible que le bouton Navigation dans NavigationMAJ ne fonctionne pas. Il suffit alors de lancer l'un ou l'autre à la mimine, et ça passe tout seul.

·         Le lancement de Navigation se fait au travers du menu "Démarrer" de Wine, ou par wine ~/.wine/drive_c/Program Files/FouFou/Navigation/Navigation.exe

Avec la version 1.4.1,  les commandes deviennent (merci à Valentin Surrel) :
(en root) apt-get install wine cabextract
wget http://kegel.com/wine/winetricks
chmod +x winetricks
./winetricks corefonts
./winetricks mdac28
Ensuite, suivre la manière d'installer de Windows. Utiliser le menu Wine pour lancer les différentes applications ou à la main :
wine ~/.wine/drive_c/Program\ Files/FouFou/Navigation/NavigationMAJ.exe
wine ~/.wine/drive_c/Program\ Files/FouFou/Navigation/NavigationConfig.exe
wine ~/.wine/drive_c/Program\ Files/FouFou/Navigation/Navigation.exe

Comment installer Navigation sous MAC

L'installation sous Mac est possible au travers de la couche gratuite WineBottler.

·         Télécharger Librairies.exe et NavigationAmorce.exe depuis mon site.

·         Télécharger Wine Bottler depuis http://winebottler.kronenberg.org/ (cliquer sur "download" juste en dessous l'image du verre dans le carton).

·         Un disque "Wine Bottler combo" va s'ouvrir en fin de téléchargement.

·         Copier Wine et WineBottler dans le répertoire "Application" du Mac

·         Ejecter "WineBottler combo" et le détruire du répertoire "Téléchargement".

·         Depuis le répertoire "Applications", lancer Wine. Si un message demande de vérifier les nouvelles versions, accepter.

·         Dans le menu de Wine, choisir "Winetricks", et cliquer sur "Apply".

·         Dans le menu de Wine, lancer "File Manager".

·         Dans l'application "File Manager", cliquer sur l'icone "/" (en haut à gauche).

·         Chercher le répertoire de l'utilisateur courant dans le répertoire "Users". Trouver le répertoire "Téléchargement" (Downloads) de l'utilisateur

·         Double cliquer sur "Librairies.exe"

·         Cliquer sur "Ok" sur l'écran de sélection de la langue, puis sur "Suivant", "J'accepte" et "Installer"

·         Double cliquer sur "NavigationAmorce.exe"

·         Cliquer sur "Ok" sur l'écran de sélection de la langue, cocher "J'accepte les termes de la licence" (si vous êtes d'accord) puis sur "Suivant", "J'accepte" et "Installer"

·         Cliquer sur "Fermer"

Pour créer des raccourcis, utiliser le Finder pour ouvrir le répertoire "Wine Files" de l'utilisateur courant,  et se positionner dans "drive_c" "Program Files" "FouFou" "Navigation".

·         Localiser le fichier Navigation.exe, le sélectionner et utiliser "Fichier" > "Créer un alias".

·         Déplacer ensuite le fichier "Navigation.exe alias" sur le bureau ou l'endroit où vous le souhaitez.

·         Répétez éventuellement l'opération avec "NavigationMAJ.exe" et NavigatonConfig.exe"..

·         Double cliquez sur l'alias pour lancer l'appli.

·         La première fois, choisir "Run directly in ..." et cochez "Don't show this dialog again", puis cliquer sur "Go"

La suite de l'installation est identique à celle sous Windows.

J’ai un problème de chargement des détails

Les détails proviennent directement d'un site américain (contrairement aux autres informations qui sont disponibles sur mon site). Malheureusement, ce site a été remanié, et la nouvelle version n'accepte pas plus de 300 connexions simultanées, d'où le message d'erreur au moment de la connexion.

Cependant, la bonne nouvelle, c'est qu'en essayant de télécharger le matin, pendant que les Américains dorment, ça fonctionne beaucoup mieux !

Je ne vois pas bien la différence après le chargement des détails

Il n'y a rien de spectaculaire avant/après le téléchargement des détails. C'est dû au fait que Navigation utilise ces fichiers dynamiquement, et affiche les versions disponibles en fonction du facteur de zoom. Par contre, lorsque vous êtes au niveau de zoom maxi, on voit une vraie différence entre un endroit ou on a chargé les détails. Le niveau de détail est 100 fois meilleur (10 x 10) que sans.

Sachant ça, vous pouvez vérifier de façon simple. Localisez le répertoire GIF0, et déplacez-le. Lancez Navigation, sur une zone où vous avez chargé les détails, et zoomez à fond, sur un AD par exemple, avec les vecteurs actifs (ça donne des points de repère). Regardez la pixelisation (les carrés). Sans sortir de Navigation, replacez le répertoire GIF0 dans le répertoire d'origine, et déplacez la fenêtre avec une des flèches (ou demandez l'affichage des VOR ou NDB, ça va réafficher l'écran). Vous allez voir très nettement la différence, surtout si vous avez affiché la fenêtre "Altitude".

Dernier point, essayez sur une zone où il y a un peu de relief. En plaine, les différences de relief sont faibles, donc peu visibles sur la carte. Dans les Alpes, par contre ...

Quels sont les formats autorisés pour spécifier une latitude/longitude ?

Navigation reconnaît plusieurs façons de spécifier latitude et longitude. Dans ce qui suit, les conventions suivantes sont appliquées :

·         P indique le pole. Peut prendre pour valeur :

Ø  "N" indique le Nord (North)

Ø  "S" indique le Sud (South)

Ø  "E" indique l’Est (East)

Ø  "O" ou "W" indiquent l’Ouest (West)

Ø  "+" indique le Nord ou l’Est

Ø  "-" indique le Sud et l’Ouest

·         dd et ddd indiquent les degrés (dd compris entre 0 et 90 pour les latitudes,  ddd entre 0 et 180 pour les longitudes)

·         mm indique les minutes (mn compris entre 0 et 59)

·         ss indique les secondes (ss compris entre 0 et 59)

·         cc indique la partie suivant le point décimal (peut être précisé sur plus de 2 chiffres)

·         des espaces peuvent être insérés n’importe où pour rendre la saisie plus lisible. Ils seront ignorés.

Les formats reconnus sont :

·         Degrés, Minutes, Secondes : Pddmmss (S 19 47 58) et ddmmssP (19 47 58 S)

·         Degrés, Minutes, Secondes décimales : Pddmmss.cc (W123 51 03.98) et ddmmss.ccP (123 51 03.98W)

·         Degrés, Minutes : Pddmm (N 17 23) et ddmmP (17 23N)

·         Degrés, Minutes décimales : Pddmm.cc (E 010 23.12345) et ddmm.ccP (010 23.12345E)

·         Degrés : Pdd (N47) et ddP (47 N)

·         Degrés décimaux : Pdd.cc (E010.73829) et dd.ccP (010.73829 E)

Afin d’éviter des erreurs d’interprétation, les degrés doivent impérativement être précisés sur 2 (latitudes) ou 3 (longitudes) caractères, minutes et secondes sur 2 caractères. Il n’y a pas de limitation sur les parties décimales. Les espaces sont supprimés avant interprétation. Il peut être judicieux d’en intégrer, pour faciliter la lecture pendant la saisie.

Quel est le format autorisé pour spécifier une déclinaison ?

En utilisant les mêmes conventions que ci-dessus, les formats autorisés sont :

·         Degrés : Pddd (W002)

·         Degrés décimaux : Pddd.cc (E001.23)

Il est évident que seuls "E", "W", "O", "+" et "-" peuvent être utilisés en tant que pole.

Je pense que mon anti-virus me pose un problème. Puis je le désactiver ?

Il arrive qu’on se pose une question vis-à-vis de l’anti-virus en cas de problème avec Navigation. La réponse à cette question se trouve dans les logs de l’anti-virus. En effet, s'il pense qu'un fichier est infecté (une DLL par exemple), il va en interdire l'accès et laisser une trace quelque part. Pour lever le doute, vous pouvez tenter d'ouvrir le fichier incriminé sous WordPad (en prenant bien soin de ne PAS enregistrer le fichier en sortant). Si vous arrivez à l'ouvrir, pas de problèmes. Si vous arrivez sur un beau fichier vide, concentrez-vous sur votre anti-virus.

Attention, la désactivation d'un anti-virus alors qu'il a détecté un virus potentiel n'est PAS une bonne chose (en fait, ça va permettre au virus de travailler). Il ne faut donc PAS désactiver l'anti-virus en cas de doute.

D’où viennent les cartes utilisées par Navigation. Qui les édite ?

Les cartes ont été crées à partir des données topographiques disponibles sur le site GTOP30 http://edcdaac.usgs.gov/gtopo30/gtopo30.html par un programme de conception maison. Chaque carte fait 1200 pixels de coté. Il existe 5 définitions différentes, utilisées de façon optimisée par le programme, en fonction du zoom. Dans la meilleure définition, la carte a un coté de 10°, ce qui fait une définition de 30 secondes d’arc, soit ½ NM, soit à peu près 900 m par pixel. Les définitions suivantes font 20°, 40°, 80° et 160° de coté. Le nombre de fichiers varie entre 648 pour 85 Mo et 8 pour 830 Ko, selon la définition.

Navigation incorpore par défaut une carte de l'ensemble de la terre dans sa définition la plus basse. Il est possible de télécharger ensuite les zones dont on souhaite avoir une définition plus haute au travers de NavigationMAJ (mise à jour), en cliquant sur le bouton carte, et en sélectionnant les zones (ou pays) intéressants. Il n'est absolument pas indispensable de charger tout.

Avec les cartes, on obtient un fond d'écran où la couleur de chaque point correspond à la hauteur (très) approximative du sol. Ces couleurs peuvent être réglés dans les options, onglet "Affichage".

De plus, depuis la version 2.6, Navigation supporte des cartes numériques utilisant des systèmes de projection divers. On est notamment capable d’utiliser la "CartaBossy".

Pour plus de détails sur les différents types de cartes, voir http://francois.fouchet.free.fr/Navigation/Aide/Cartes.htm#Les_differents_types_de_cartes

Comment se procurer un exemplaire de la CartaBossy numérique ?

La "CartaBossy" (du nom de son auteur, Jean Bossy) est disponible à http://www.cartabossy.com/ au prix de 17€50 pour la version France et 12€50 pour la version France Week End.

Ces prix comprennent une version électronique des cartes, à télécharger sur site.

Elles s'intègrent facilement dans Navigation :

1.       Télécharger la version ECW au format ZIP depuis e-cartabossy (les identifiants sont fournis envoyés par mail après l'achat d'une version papier)

2.       Créer un répertoire dans le répertoire \Cartes de Navigation (par exemple \CartaBossy 2015 ou \CartaBossy 2015 WE)

3.       Décompresser le contenu du zip dans ce répertoire.

Utilisation des cartes IGN France OACI

Navigation supporte l’affichage des cartes IGN "France OACI" au format ECW.

L’installation consiste simplement à copier les fichiers "France xx.ecw" et "Corse.ecw" téléchargés depuis de site de l'IGN vers le répertoire \Cartes\IGN France 2015 de Navigation (par défaut, le chemin complet est C:\Program Files\FouFou\Navigation\Cartes\IGN France 2015).

Une fois ces fichiers copiés, la liste déroulante présente sur l’écran principal de Navigation peut être utilisée pour choisir l’item "IGN France 2015".

Le coût de la carte est de 70€ pour la France complète (Corse comprise), 15€ un quart de France, 10€ pour la Corse. Cette commercialisation est indépendante de Navigation. Je n’ai aucun lien financier avec l’IGN.

Plus d’infos à http://espaceloisirs.ign.fr/boutique/catalogsearch/result/index/?ign_type_impression=T%C3%A9l%C3%A9chargeable&q=oaci

Le fond de mes cartes est uniforme, alors qu’avant la couleur dépendait de l’altitude. Que faire ?

L’icône représentant une roue multicolore de la barre d’outils permet d’uniformiser le fond de carte (utilisé en l’IFR). Vous avez dû cliquer dessus par inadvertance. Recliquez pour corriger le problème.

Il est également possible que vous ayez demandé d’afficher les vecteurs (en cochant la case "Vecteurs"), tout en demandant l’affiche de l’item "Terre", ce qui recouvre le fond de carte aux endroits où la terre est présente sur le globe. Pour vérifier/modifier cet élément, ouvrez la fenêtre "Légende" (cliquez sur l’icône "Légende" représenté par 3 lignes précédées de carrés de couleur, ou utilisez le menu "Affichage" > "Légende"), et décochez l’item "Terre".

Quelles différences entre cartes, vecteurs et données aéro ?

Par défaut, Navigation installe une carte "Totalité du globe" qui a pour définition de base de 1 pixel pour 256 km2, occupant 830 Ko, ce qui donne un niveau de détail peu satisfaisant localement, mais permet d’avoir une carte du monde lisible.

En utilisant le bouton "Cartes" de l'outil de mise à jour, on peut choisir les zones sur lesquelles ont souhaite une définition de 1 pixel par carré de 900 m de coté. Là, c'est déjà vraiment mieux. Mais on est à 800 fichiers et 85 Mo pour couvrir l'ensemble de la terre.

Le top du top, c'est le bouton "Détail, qui amène à un pixel pour 90 m de coté. La mauvaise nouvelle, c'est que la couverture globale de la terre occupe entre 4 et 5 Go sur le disque dans ce cas là. On choisit donc les zones d'intérêt pour minimiser la place prise sur disque (d'autant qu'il y a des coins du monde où on n'ira jamais voler).

"Vecteurs", de son coté,  permet de charger des données vectorielles, qu'on peut afficher à la demande. On y trouve le contour des pays, les routes, les fleuves, les lignes HT, les villes et les voies ferrées. Au lieu d'être gravées dans le marbre d'un fichier bitmap, ils sont stockés en base de données, et affichés à la demande, de façon individuelle, avec les couleurs, épaisseurs et types de trait que vous souhaitez. Les coordonnées de chaque segment sont stockées sous forme longitude/latitude de début/fin, et ils sont tracés à partir de ces infos. Ils sont de ce fait insensibles au facteur de zoom. Il est clair que c'est beaucoup plus souple, mais que çà coûte un peu en temps d'affichage, et en stockage (la France "pèse" 17 Mo, l'Europe le double). Heureusement, ces données sont compressées pendant le transfert, ce qui fait que vous en téléchargez sensiblement moins.

La case à cocher "Vecteurs" n'est accessible que s'ils ont été téléchargés (au moins 1 fichier). On peut voir les zones téléchargées dans le menu "?" > "A propos" > "Vecteurs".

Coté Navigation, la case à cocher "Cartes" correspond (de façon peu habile) aux documents qu'on peut télécharger sur des sites externes (par exemple, les VAC depuis le site du SIA). J'aurais pu l'appeler "VAC", mais on trouve aussi des "IAC", "AD2", "SID/STAR", ...). Ces fichiers sont sélectionnés onglet "Documents" des options. Ils se téléchargent par me biais du menu "Outils" > "Documents". Si on a installé l'outil gratuit "GhostScript" sur la machine, et coché la bonne case dans l'onglet "Documents", Navigation extraira les "images" des VAC, et validera la case à cocher "Cartes".

Je suis d'accord avec ceux qui expliqueront que ce n'est pas très logique ... Si un jour j'ai du temps, je reprendrais globalement l'ergonomie de Navigation, l'actuelle ayant subi pas mal de modifications depuis son origine (en 2001) ...

Concernant les autres possibilités du sélecteur "Totalité du globe", on trouve "CartaBossy", "France OACI" et "Jeppsen Europe". Ces sélections permettent de définir une projection différente de celle par défaut (qui est une projection cylindrique équidistante). Elles permettent d'avoir une représentation à peu près correcte de la France ou de l'Europe. Pour les 2 premières, elles permettent aussi d'utiliser les fonds cartographiques diffusés par Jean BOSSY (pour la CartaBossy) et l'IGN (pour France OACI). Ces cartes sont payantes (voir ici et ici). Je précise que je ne suis lié ni avec l'un, ni avec l'autre, et que je ne touche pas un cent d'Euro sur ces cartes.

On peut aussi, par ce biais, définir sa propre projection, et, avec certaines limitations, ajouter ses propres cartes. Navigation utilise des cartes et les affiche en fond d'écran. Ces cartes indiquent la hauteur du sol, au moyen de couleurs différentes. Elles sont téléchargeables après avoir cliqué sur le bouton "Cartes" de l'outil de mise à jour.

Par dessus ces cartes, Navigation affiche des données, telles qu'aéroports, NDB, VOR, points, classes, zones, routes IFR, ... Ces données aéronautiques sont téléchargeables par pays et mises à jour tous les 28 jours, à partir de l'écran principal de l'outil de mise à jour (par exemple Données France, Données Italie IFR, ...)

Pourquoi les vecteurs ne s’affichent ils pas chez moi ?

Pour que les vecteurs s’affichent sur l’écran il faut :

  1. télécharger les vecteurs et les installer
  2. cocher "Vecteurs" sur l'écran principal de Navigation
  3. cocher au moins 1 élément dans la partie consacrée aux vecteurs dans la fenêtre légende
  4. que le facteur de zoom permette d'afficher les vecteurs. Ceci est défini dans les options, onglet "Défauts", et réglé par "Ne pas afficher les vecteurs au delà de xx NM". C'est souvent cette dernière condition qui est "oubliée". Pour ne plus être concerné par cette option, soit vous zoomez suffisamment pour que les vecteurs s'affichent, soit vous remontez la limite. Attention, si la limite est trop élevée, vous aurez trop de vecteurs affichés, et des performances dégradées.

Comment télécharger les vecteurs dans le cas d’une installation sans connexion à Internet ?

Pour installer les vecteurs de la France dans le cas d’une installation sans connexion à Internet, téléchargez, sur une machine avec un accès à Internet (mais sans Navigation installé) les fichiers suivants :

VecteursVide.zip

Vecteurs_W000E030N45N30.zip

Vecteurs_W000E030N60N45.zip

Vecteurs_W030W000N45N30.zip

Vecteurs_W030W000N60N45.zip

Copiez-les ensuite dans le répertoire de Navigation sur le PC où il est installé. Lancez NavigationMAJ et validez l’installation de chaque fichier. Il est possible que NavigationMAJ râle en fin d’installation, parce qu’il va essayer de se connecter à Internet. Ça n’est pas grave…Lancez enfin Navigation pour intégrer proprement les vecteurs téléchargés.

Comment afficher les cartes VAC dans Navigation ?

Navigation permet d’incruster, au bon endroit, sur la carte qui sert de fond, les cartes VAC des terrains. C'est un peu approximatif (en effet, les projections ne sont pas gérées, et il y a un léger effet de déformation en dehors de la zone centrale de la projection), mais ça donne une bonne idée.

Comment ça fonctionne ? On récupère les VAC (française) sur le site du SIA. A l'aide de GhostScript, les cartes sont converties en JPEG, puis elles sont extraites par Navigation (on ne conserve que l'image). Le calage est réalisé automatiquement (à partir de tables), ce qui fait qu'elles s'affichent au bon endroit (c'est magique !).

Pour que ça fonctionne, il faut :

1)      avoir installé GhostScript (gratuit, téléchargeable à http://downloads.ghostscript.com/public/gs916w32.exe en version 32 bits ou http://downloads.ghostscript.com/public/gs916w64.exe en version 64 bits, la liste des versions étant à http://www.ghostscript.com/download/gsdnld.html)

2)      avoir coché "Utiliser GhostScript" dans l'onglet "Documents" des options

3)      récupérer les VAC qu'on veut afficher (soit on sélectionne les cartes une par une, par clic droit sur un terrain, puis "Télécharger documents", soit on les choisit globalement par "Outils" > "Documents" > "Télécharger tout les documents")

4)      cocher sur l'écran principal la case "Cartes"

5)      vérifier, si vous affichez les vecteurs, que la case "Terre" de la fenêtre "Légende" n'est pas cochée (sinon, le terrain va masquer la carte)

6)      zoomer suffisamment pour que la carte s'affiche

On peut choisir les cartes en cliquant sur l'icône "Cartes" (juste après le l’icône "I" pour Informations), ou par le menu "Affichage" > "Cartes additionnelles". La fenêtre qui s'ouvre permet de choisir les cartes à afficher (celles qui sont cochées). Le sélecteur permet de choisir les différentes listes à montrer :

·         Toutes : c'est écrit dessus

·         Général : ce sont les cartes positionnant globalement l'AD. En général, elles montrent une région, sans détailler l'AD lui même.

·         Détail : ce sont les cartes détaillées de l'AD

·         Ecran : ce sont les cartes des AD visibles sur l'écran actuel

·         Clic souris : indique la liste des cartes disponibles pour le dernier point sur lequel on a cliqué avec la souris (où celui sur lequel on peut cliquer ensuite).

On choisi ensuite, à partir des listes, ce qu'on veut voir (coché) ou ne pas voir (décoché). On peut changer l'ordre d'affichage par cliqué/glissé des cartes dans la fenêtre de sélection. Par défaut, les cartes sont affichées par ordre de surface de la carte (les plus grandes en dessous).

Comment charger les cartes VAC sur mon iPhone ?

Il y a plusieurs outils qui permettent de charger des fichiers sur un iPhone et de les lire.

Personnellement, j'ai choisi FileApp Pro, outil gratuit, sans limite de taille de fichiers, utilisable avec une synchronisation USB (au travers d’iTunes) et par serveur FTP intégré en mode Wifi (à peu près 20 fois plus rapide que l'USB). A télécharger sur l'Apple Store et installer sur l'iPhone.

Si on veut utiliser l'USB, rien d'autre à faire que de connecter l'iPhone. Dans iTunes, cliquer sur l'iPhone sous "Appareil", aller dans l'onglet "Application", faire défiler la page pour afficher "Partage de fichier", cliquer sur "FileApp Pro", et ajouter les VAC à l'aide du bouton "Ajouter" dans la partie droite. Les VAC se trouvent par défaut dans le répertoire \VAC de Navigation (C:\Program Files\FouFou\Navigation\VAC si on ne touche à rien). Les SIV se trouvent par défaut dans le répertoire \SIV VAC de Navigation (C:\Program Files\FouFou\Navigation\SIV si on ne touche à rien). La synchro prend un certain temps …

Si on veut aller (beaucoup) plus vite, on peut utiliser le mode FTP. Il faut un client FTP sur le PC. Là encore, il y en a plusieurs. Pour ma part j'utilise l'outil gratuit FileZilla (http://www.filezilla.fr/).

Lancer FileApp Pro sur l'iPhone. Cliquer sur l'icône Wifi en haut à droite (un point surmonté de 3 quarts de cercle). Un écran "Sharing" apparaît. Cliquer sur Wifi pour avoir l'adresse IP du serveur FTP (l'écran indique par exemple ftp://192.168.0.8:2121).

Cote PC, lancer FileZilla, dans la case host, saisissez l'adresse IP de l'iPhone (par exemple 192.168.0.8) et dans la case port 2121. Cliquez sur "Connexion rapide".

Ensuite, sélectionner " C:\Program Files\FouFou\Navigation\" dans la partie gauche de l'écran, cliquer sur \VAC et le faire glisser sur la partie droite. Faire de même pour \SIV.

Enfin, sortir proprement des programmes sur le PC et sur l'iPhone.

En ce qui me concerne, j'y copie également les NOTAM, récupérés par un clic droit "Imprimer" sur une imprimante "PDF Creator" (encore un logiciel gratuit) depuis la fenêtre "Outils" > "NOTAM" de Navigation, et les cartes météo toujours générées par "PDF Creator" depuis les fenêtres "Outils" > "Météo" > … de Navigation.

J'ai eu une erreur pendant le téléchargement. En relançant, les mêmes fichiers sont retéléchargés. Pourquoi ?

L'installation de Navigation s'effectue selon 2 modes :

·         soit directement par l'application de mise à jour. C'est le cas pour Navigation, et de façon générale, des extensions de Navigation

·         soit en coopération entre la mise à jour et Navigation. C'est le cas notamment pour la mise à jour et les données au sens large. Dans ce dernier cas, si un fichier a été téléchargé, mais que vous ne lancer pas Navigation avant de relancer la mise à jour, celle ci redemandera sont téléchargement, l'installation de l'élément n'ayant pas été terminée par Navigation.

Pour corriger ce problème, il existe une solution simple : lancez Navigation après chaque lancement de la mise à jour, même dans le cas où cette dernière s'est mal déroulée.

Les cartes apparaissent aplaties

Ce phénomène est dû au fait que, sur la carte "Totalité du globe", Navigation n'utilise pas de système projection. Du coup, un cm sur l'écran représente la même "distance" en degrés de latitude et de longitude. L'ennui, c'est que sur la terre, un degré de longitude représente 1/360eme de son diamètre au niveau de l'équateur, et ... zéro aux pôles, en passant par toutes les valeurs intermédiaires entre les 2. Si on regarde un petit cercle à l'équateur, on verra un cercle, en France une ellipse, au pôle une droite.

La solution consiste à utiliser une carte avec un système de projection (telle que la CartaBossy). L'inconvénient, c'est que le système de projection, dont le but est de se "débrouiller" pour que les distances soient à peu près égales sur les 2 axes, n'est valable que pour une zone donnée. Du coup, l’affichage de la totalité de la surface de la terre avec ce système donne des résultats amusants (affichez la CartaBossy et zoomez jusqu’à voir le pôle Nord, en ayant demandé l’affichage du quadrillage pour avoir une idée). Plus moyen non plus d'avoir quelque chose de correct dans le cas de navigations sur plusieurs pays. A vous de choisir entre les cercles ronds où un affichage étendu.

Je n’arrive pas à utiliser mon GPS

Il y a plusieurs choses à vérifier lorsqu'on rencontre des problèmes de connexion avec un GPS.

1)      Demander à Navigation de chercher le GPS. Mettre le GPS sous tension, connectez-le au Pc, lancez Navigation, ouvrir les options ([F12] ou "Outils" > "Options" > "Modifier"), cliquez sur l'onglet "GPS", et cliquer sur "Trouver GPS". En général, Navigation trouve assez bien les GPS et leur paramétrage.

2)      Vérifier, dans les menus du GPS, qu'il est bien paramétré pour fonctionner en connexion avec un PC (protocole et vitesse). Choisir le protocole de la marque du GPS si Navigation le supporte (c'est le cas des Garmin entre autres).
Selon le modèle, la vitesse peut être choisie (ou pas). Garmin fonctionne très bien à 9600 Bds.

3)      Vérifier, dans les options, onglet GPS, qu'on a bien paramétré Navigation. D'abord s'assurer qu'on est bien connecté sur le bon port COM (certaines machines disposent de plusieurs ports). Attention au fait que certaines cartes modem interne peuvent être considérées comme COM1, laissant le port COM en face arrière sur COM2. Ça dépend vraiment du PC.
On peut habilement utiliser le bouton "?" situé à gauche du nom du port COM afin d'afficher un cadre dans lequel les trames émises par le GPS (qu'on aura pris soin de paramétrer pour qu'il envoie des trames NMEA en se référant à la doc du GPS). Une fois "?" cliqué, il suffit de jouer avec les différents paramètres (port, vitesse, parité, …) jusqu'à ce que le cadre "Données GPS" indique des choses commençant par "$GP" ou "$PMG".
Sinon, un petit tour dans les propriétés du poste de travail, onglet "Matériel", clic sur "Gestionnaire de périphériques" peut aider. Dans tous les cas, on ne risque rien à essayer les ports un par un. Vérifier ensuite que le protocole (et le checksum) utilisé est bien celui définir dans les menus du GPS. Mettre également la bonne vitesse. Là encore, on peut y aller à tâtons, on ne craint rien à essayer les différentes vitesses.

4)      Les connexions GPS sont extérieurement de 2 types : port COM ou port USB. Une ambiguïté liée aux ports USB est que, pour certains GPS, le port USB est utilisé pour simuler un port COM. Dans ce cas spécifique, bien que le GPS soit connecté sur un port USB, Navigation l'utilisera au travers du port COM virtuel associé. Là encore, la solution se trouve dans les propriétés du poste de travail, onglet "Matériel", clic sur "Gestionnaire de périphériques". Aller dans la rubrique "Ports COM et LPT", et noter les numéros de port COM présents sur la machine.

Si vous n'arrivez pas à vous en sortir comme ça, le paragraphe suivant peut aider à trouver le bon port, et la bonne vitesse, en tâtonnant un peu.

L'idée est de passer le GPS en mode NMEA, et de lui faire envoyer en continu les séquences de positionnement NMEA. Ça se paramètre dans le GPS, en général au travers des menus de configuration "communications". Une fois le GPS paramétré, il envoie des séquences toutes les 1 à 2 secondes. Ces séquences sont de la forme "$GPxxx". Pour les voir, on utilise, dans les accessoires, l'hyper terminal de Windows. On teste les différents ports COM, un par un, jusqu'à en trouver un qui envoie des "trucs" régulièrement. On a donc trouvé le port.

Reste ensuite à caler la vitesse, pour que les séquences soient visibles. En général, la vitesse est de 4800 bds, sauf  pour les Garmin où on utilise souvent 9600 bds. Voici un exemple de la tête que ça doit avoir (ne pas s'attacher aux détails, qui varient selon le GPS) :

$GPGSA,A,3,20,25,11,01,,,,,,,,,4.4,2.4,3.7*34

$GPGSV,3,1,09,20,79,327,47,11,58,122,54,01,42,182,51,07,40,291,*77

$GPGSV,3,2,09,25,19,076,46,13,14,200,,04,09,301,,14,03,037,*75

$GPGSV,3,3,09,28,00,246,,,,,,,,,,,,,*4A

$GPGLL,4506.4024,N,00131.0757,E,192208.625,A*36

$GPGGA,192208.63,4506.4024,N,00131.0757,E,1,04,2.4,00253,M,,,,*21

$GPRMB,A,0.00,L,NOAILL,B01P02,4509.6177,N,00128.7972,E,003.6,333.,000.0,V*17

$GPRMC,192208.63,A,4506.4024,N,00131.0757,E,00.0,000.0,020302,02.,W*7D

$GPAPB,A,A,0.0,L,N,,,335.1,M,B01P02,335.1,M,,,*55

Quand vous voyez ça, vous notez soigneusement le port et la vitesse et vous allez dans les options de Navigation pour lui donner le bon port et la bonne vitesse.

Il peut être habile de repasser le GPS dans un mode plus adapté (en général les modes propriétaires permettent de faire plus de choses que le mode NMEA).

Comment connecter mon GPS Garmin à Navigation ?

Tout d’abord, il faut que vous paramétrer correctement les options, spécifiquement l'onglet GPS. Sur cet écran, il faut indiquer le port COM sur lequel est connecté le GPS, ainsi que la vitesse. En général, les Garmin sont 9600/8/N/1 (mais ça peut être modifié dans les paramètres du GPS, voir sa doc).

Ensuite, il faut déclarer le mode dans lequel le GPS va travailler. Suivant les modèles Garmin, on a le choix du protocole de dialogue entre le PC et le GPS ou pas. Le mode propriétaire "Garmin", checksum "Garmin" est toujours disponible. De plus, sur certains modèles, le mode normalisé NMEA 2.0 peut être choisi dans les paramètres du GPS (voir la doc du GPS). Si c'est le cas, il faut paramétrer Navigation en mode "NMEA", checksum "NMEA".

Si on souhaite n'avoir que le positionnement sur la carte (item "Position en temps réel" du menu "GPS"), le mode NMEA est à mon avis bien meilleur. Par contre, il n'est pas possible de "vider" le contenu du GPS sur le PC en mode NMEA. Si vous souhaitez le faire, il faudra modifier le paramétrage du GPS sur le GPS lui même (voir la doc), puis dans Navigation ("Affichage" > "Options" onglet "GPS").

Sur le Garmin Pilot III, le paramétrage se fait sur "Main Menu" > "Setup" > "Interface".

Enfin, ne pas oublier que sur certains GPS, il faut utiliser le paramétrage afin de lui demander d'envoyer sur le port COM les séquences de paramétrage en temps réel (là encore, RTFM).

Si vous avez un modèle USB, la dernière version de driver se trouve à http://www8.garmin.com/support/download_details.jsp?id=591

Pourquoi ai-je des doublons dans mon GPS lors du chargement d’une route depuis Navigation ?

Je n'ai pas trouvé de solution réellement efficace pour régler le problème des waypoints. En effet, selon les GPS, et les versions de données, les points divergent fortement d'un équipement à l'autre. Et comme il n'y a pas de standard dans le nommage des points (en dehors des codes OACI des terrains, et des identifications des balises), c'est assez difficile de faire quelque chose de propre. Des exemples ? Avez-vous le point Novembre de Moisselles (LFFE où je vole) dans votre GPS ? Si oui, comment s’appelle-t-il (FE/N, FE-N, LFFE N, MOISSELLES N, ...). Avez-vous le VOR BDX (Bordeaux) ? Si non, c'est une erreur, il existe maintenant un VOR/DME depuis fin 2003, en plus du VOR/TACAN BDX.

La vrai solution consisterait à vider la base GPS dans le PC, et à établir une correspondance entre les points GPS et la base de Navigation. L'ennui, c'est qu'aucun fabriquant n'a crée de séquence pour faire ça, de peur de se faire piquer la base des points ... Reste une solution : demander à l'utilisateur, pour chaque point de la base de Navigation, de donner son identifiant sur le GPS. Le problème, c'est qu'il y a environ 450 AD OACI, 100 privés, 400 ULM, plus d'une centaine d'aides radio-nav, 900 points de report IFR, 500 points VFR ... ça, c'est juste pour la France. Si vous avez une base Europe, vous voyez un peu les dégâts ...

Du coup, j'ai crée une identification propre à Navigation, très souvent redondante avec celle des GPS, mais qui fonctionne à tout les coups !

La bonne nouvelle, c’est que j’ai trouvé une combine avec les GPS Garmin récents. Au moins, ce problème ne se pose pas avec ces GPS.

Comment réaliser une nav circulaire ?

Une navigation circulaire est une navigation où l’AD de départ est l’AD d’arrivée. La méthode intuitive ne fonctionne pas dans ce cas, car le fait d’approcher le curseur sur l’AD de départ positionne automatiquement le point d’insertion sur cet AD. Du coup, un double clic insère nouveau le point juste derrière le point de départ. Pour s’en sortir, il  existe plusieurs façons de procéder :

·         cliquer sur le dernier point de la nav, dans la fenêtre "Route", appuyer sur "CTRL" et "MAJ" et double cliquer sur l'AD de départ sur la carte. On peut aussi faire un clic droit "Ajouter" > "LFxx-A-LF" au lieu de double cliquer.

·         faire un clic droit sur la carte, sur le dernier point saisi, "Ajouter" > "Un point", puis saisir un bout du code OACI ou du nom de l'AD.

·         double cliquer sur l'AD de départ sur la carte. Ca va doubler le premier point. Cliquer sur ce point dans la fenêtre "Route", garder la souris enfoncée et faire glisser le point vers le bas de la liste puis relâcher le bouton de la souris "sur" le dernier point de la nav.

·         afficher le log de nav ("Affichage" > "Log de nav"), se positionner sur le dernier point de la nav, cliquer sur le "+" à coté du nom du dernier point, ce qui va créer un nouveau point, cliquer sur le nom du point crée (il est vide), et saisir un bout du code OACI ou du nom de l'AD.

J’ai une erreur 440 "Erreur Automation" lors de l’édition de mon log de nav

Très souvent, ce problème survient avec une version non à jour d’Excel 97. On voit ça dans le menu "?", "A propos de Microsoft Excel", la première ligne de la fenêtre affiche "Microsoft (R) Excel 97 SR-2". Si ce n'est pas ce que vous avez (rien derrière 97, ou SR-1), il faut mettre à jour Excel. Bonne nouvelle, c'est gratuit. Allez sur le site de Microsoft, et télécharger les services pack 1 et 2 d'XL 97 (ou simplement le 2 si le SR-1 est déjà installé), puis installez SR-1 puis SR-2 (même remarque que précédemment). Ensuite, tout devrait mieux fonctionner ...

Où trouver les services pack 1 et 2 pour Office 97 français ?

Les fichiers contenant les services pack & et 2 d’office 97 français sont à :

http://download.microsoft.com/download/office97pro/SR1Off9/SR-1/WIN98/FR/SR1Off97.exe

http://download.microsoft.com/download/office97pro/sr2bof97/sr-2b/win98/fr/sr2bof97.exe

Si vous voulez retrouver la façon de faire :

·         http://www.microsoft.fr

·         cliquer sur "Téléchargements" dans la barre du haut

·         cliquer sur "Office", à gauche, dans la partie "Produits"

·         cliquer sur "Versions précédentes", à gauche

·         cliquer sur l'onglet "Office 97", au milieu de l'écran

·         cliquez sur "Téléchargez les compléments logiciels, les modèles et les mises à jour produit et sécurité sur le centre de téléchargement Office"

·         http://office.microsoft.com/france/downloads/default.aspx

·         choisir "Office" (ou "Excel" si vous n'avez qu'Excel installé sur votre machine)

·         choisir "97/98" dans la version

·         cliquez sur "Mise à jour de la liste"

·         téléchargez SR-1 et SR-2b

Quelle est la version minimale d'OpenOffice supportée ?

Navigation supporte OpenOffice à partir de la version 2.0. Cependant, OpenOffice n'étant plus développé, je vous conseille de passer à LibreOffice, également gratuit, qui évolue régulièrement. On peut le télécharger depuis http://www.libreoffice.org

Attention, Navigation ne peut pas piloter LibreOffice quand le lancement au démarrage de Windows est positionné. Veillez à ne pas ne PAS cocher "Chargement de LibreOffice au démarrage du système" dans la partie "Mémoire vive" des options de LibreOffice

Si vous obtenez un message d'erreur relatif aux macros, ou que vous voyez des signes #MACRO# sur les feuilles, allez dans les options de LibreOffice, partie "Sécurité", après avoir cliqué sur "Sécurité des macros ...", choisir l'onglet "Source de confiance" et indiquer le répertoire d'installation de Navigation (par défaut C:\Program Files (X86)\FouFou\Navigation\) dans la partie "Emplacement des fichiers de confiance" (cliquer sur "Ajouter" pour spécifier le répertoire).

Un souci régulièrement remonté concerne les performances de LibreOffice. L'exécution des macros natives est assez lente. Il y a une combine qui consiste à utiliser la capacité à exécuter des macros Excel directement. Les performances sont très nettement améliorées par rapport à un fonctionnement natif. Dans ce cas, choisir "NavigationOpenOffice.XLS" comme fichier à utiliser pour l'impression dans l'onglet "Défauts" des options de Navigation, en bas à gauche, et "Mode Excel sous OpenOffice".